Minimum requirements


Swift Language Version >= 5

Unflow VersionMinimum XCode VersionSupported iOS Versions
Unflow 1.13.0-swift-5.6XCode 13.4.1 (SDK 15)iOS 11*, 12*, 13, 14, 15, 16
Unflow 1.13.0XCode 14.0 (SDK 16)iOS 11*, 12*, 13, 14, 15, 16
Unflow 1.3.0XCode 13.3.1 (SDK 15)iOS 11*, 12*, 13, 14, 15
Unflow 1.2.0 - 1.2.2XCode 12.4 (SDK 14)iOS 11*, 12*, 13, 14, 15

* Unflow compiles on apps supporting iOS 11 & 12 but only supports devices on iOS 13 and above. As of 11th January 2022, more than 98 percent of all active devices introduced in the last four years can use your product if your app supports iOS 11 upward. See Mixpanel statistics or Apple’s official device statistics for details.

It is possible for your app to support an older version of iOS that isn’t supported by Unflow as the SDK will only initialize when running on newer iOS versions.

Architectures and Device Support

Unflow supports ARM64 and x86_64, including bitcode for both architectures.

Unflow for iOS supports all available iPhone devices and form factors and includes many adjustments for optimal display for small and large screens.

For a detailed overview of iOS device compatibility, see the list of supported iOS releases.

Xcode Support

Apple requires that all apps submitted to the App Store be built with Xcode 13 and the iOS 15 SDK or later.

In general, the most recent build will always require the most recent stable version of Xcode so that we can utilize all the improvements Apple is making on its tools and compiler infrastructure.

When a major xcode version change happens, we'll support the old version and the new version of Xcode at the same time. At present, that means we support both Xcode 14 and Xcode 13.4.1. We will not support any further 13 versions, but our SDK will be built with Swift 5.6 compliant code to ensure you can build it. This will be in place until Apple requires Xcode 14 be used for the App Store.


compileSdkVersion >= 32

targetSdkVersion >= 32

minSdkVersion >= 21

buildToolsVersion >= 30.0.0

React Native

react-native >= 0.63.4

expo >= 41 (if you use Expo)

typescript >= 4.1.0 (if you use TypeScript)